CVE-2018-14523 is a high-severity (CVSS 8.8) Out-of-bounds Read vulnerability in aubio. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for aubio — see the affected versions and patch details below.
Aubio is vulnerable to out of bound read when samplerate > 50kHz
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
aubioReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in aubio 0.4.6. A buffer over-read can occur in new_aubio_pitchyinfft in pitch/pitchyinfft.c when the samplerate of the input file is larger than 50kHz.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | aubio | all versions | 0.4.7pip install --upgrade 'aubio==0.4.7' |
Affected Products
aubioaubioleapopensuselinux enterprisesuseResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aubio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aubio to 0.4.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-14523 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2018-14523 in your dependencies?
Find it across PyPI, including transitive dependencies.