CVE-2018-16887 — katello
MEDIUMCVE-2018-16887 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in katello. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for katello — see the affected versions and patch details below.
katello Cross-site Scripting vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
katelloReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
A cross-site scripting (XSS) flaw was found in the katello component of Satellite. An attacker with privilege to create/edit organizations and locations is able to execute a XSS attacks against other users through the Subscriptions or the Red Hat Repositories wizards. This can possibly lead to malicious code execution and extraction of the anti-CSRF token of higher privileged users. Versions before 3.9.0 are vulnerable.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | katello | all versions | 3.9.0bundle update katello --conservative |
Affected Products
satelliteredhatkatellotheforemanResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for katello, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update katello to 3.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-16887 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Subscription Asset Manager does not support the Organization Change, and therefore is not affected by this flaw.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.5 for RHEL 7 | ansiblerole-insights-client-0:1.6-1.el7sat | RHSA-2019:1222 |
Frequently Asked Questions
Is CVE-2018-16887 in your dependencies?
Find it across RubyGems, including transitive dependencies.