CVE-2026-12515 is a medium-severity (CVSS 4.3) CWE-862 vulnerability in katello. A fix is available for katello — see the affected versions and patch details below.
katello: missing repository authorization in content_uploads exposes cross-product content existence
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-12515.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
katelloReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Katello's of Red Hat Satellite. A content upload functionality where insufficient authorization checks in the ContentUploadsController allowed users with the edit_products permission to query content information for repositories outside the products they were authorized to manage. An authenticated attacker could exploit this issue to determine whether specific content exists within repositories that should otherwise be inaccessible. This issue does not allow unauthorized modification, import, or publication of content.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | katello | all versions | 4.21.0.rc1bundle update katello --conservative |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for katello, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update katello to 4.21.0.rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-12515 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability affects Katello's content upload API authorization handling. Red Hat Product Security has assessed this issue as a Moderate severity vulnerability. Katello's content_uploads API does not properly enforce repository authorization checks when processing upload requests. A user with product-filtered…
Red Hat is not aware of a practical temporary workaround that fully mitigates this issue or meets Red Hat Product Security's standards for usability, deployment, applicability, or stability. Customers are advised to apply the relevant security updates if they become available.Source: Red Hat security advisory for CVE-2026-12515 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.16 for RHEL 8 | rubygem-katello-0:4.14.0.21-1.el8sat | RHSA-2026:50223 |
| Red Hat Satellite 6.17 for RHEL 9 | rubygem-katello-0:4.16.0.18-1.el9sat | RHSA-2026:50222 |
| Red Hat Satellite 6.18 for RHEL 9 | rubygem-katello-0:4.18.0.15-1.el9sat | RHSA-2026:50263 |
| Red Hat Satellite 6.19 for RHEL 9 | rubygem-katello-0:4.20.0.7-1.el9sat | RHSA-2026:50221 |
Frequently Asked Questions
Is CVE-2026-12515 in your dependencies?
Find it across RubyGems, including transitive dependencies.