NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-14773 — http-foundation

MEDIUMFix: symfony/symfony@e447e8b

CVE-2018-14773 is a medium-severity (CVSS 6.5) vulnerability in symfony/http-foundation. EPSS puts its 30-day exploitation probability at 57.6% (99th percentile). A fix is available for symfony/http-foundation — see the affected versions and patch details below.

Symfony HTTP Foundation web cache poisoning

Also known asGHSA-8wgj-6wx8-h5hq
Published
Updated
Affected
12 pkgs
Patched
12 / 12
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
57.6%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
4.23%26.3%48.4%70.5%16.7%57.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

12 pkgs affected
🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/symfony🐘symfony/symfony+4 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. It arises from support for a (legacy) IIS header that lets users override the path in the request URL via the X-Original-URL or X-Rewrite-URL HTTP request header. These headers are designed for IIS support, but it's not verified that the server is in fact running IIS, which means anybody who can send these requests to an application can trigger this. This affects \Symfony\Component\HttpFoundation\Request::prepareRequestUri() where X-Original-URL and X_REWRITE_URL are both used. The fix drops support for these methods so that they cannot be used as attack vectors such as web cache poisoning.

Affected Packages

12 total 12 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymfony/http-foundation≥ 2.7.0&&< 2.7.492.7.49composer require symfony/http-foundation:^2.7.49
🐘Packagistsymfony/http-foundation≥ 2.8.0&&< 2.8.442.8.44composer require symfony/http-foundation:^2.8.44
🐘Packagistsymfony/http-foundation≥ 3.0.0&&< 3.3.183.3.18composer require symfony/http-foundation:^3.3.18
🐘Packagistsymfony/http-foundation≥ 3.4.0&&< 3.4.143.4.14composer require symfony/http-foundation:^3.4.14
🐘Packagistsymfony/http-foundation≥ 4.0.0&&< 4.0.144.0.14composer require symfony/http-foundation:^4.0.14
🐘Packagistsymfony/http-foundation≥ 4.1.0&&< 4.1.34.1.3composer require symfony/http-foundation:^4.1.3

Affected Products

3 products · 9 configurations
OS
debian linuxdebian
2 versions
8.09.0
Application
drupaldrupal
≥ 8.0.0 && < 8.5.6
range
Application
symfonysensiolabs
≥ 4.1.0 && ≤ 4.1.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/http-foundation, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symfony/http-foundation to 2.7.49 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-14773 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. It arises from support for a (legacy) IIS header that lets users override the path in the request URL via the X-Original-URL or X-Rewrite-URL HTTP request header. These headers are designed for IIS support, but it's not verified that the server is in fact running IIS, which means anybody who can send these requests to an application can trigger this. This affects \Symfony\Component\HttpFoundation\Request::pr
O3 Security · Impact-Aware SCA

Is CVE-2018-14773 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-14773: http-foundation — Fixed in 2.7.49