NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2015-2309 — http-foundation

MEDIUMFix: symfony/symfony#14166

CVE-2015-2309 is a medium-severity (CVSS 5.3) vulnerability in symfony/http-foundation. A fix is available for symfony/http-foundation — see the affected versions and patch details below.

Symfony has unsafe methods in the Request class

Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of May 30, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

6 pkgs affected
🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, 2.5.X, and 2.6.X versions of the Symfony HttpFoundation component are affected by this security issue.

This issue has been fixed in Symfony 2.3.27, 2.5.11, and 2.6.6. Note that no fixes are provided for Symfony 2.0, 2.1, 2.2, and 2.4 as they are not maintained anymore.

Description

The Symfony\Component\HttpFoundation\Request class provides a mechanism that ensures it does not trust HTTP header values coming from a "non-trusted" client. Unfortunately, it assumes that the remote address is always a trusted client if at least one trusted proxy is involved in the request; this allows a man-in-the-middle attack between the latest trusted proxy and the web server.

The following methods are impacted: getPort(), isSecure(), and getHost(), and getClientIps().

Resolution

All impacted methods now check that the remote address is trusted, which fixes the issue.

The patch for this issue is available here.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymfony/http-foundation≥ 2.0.0&&< 2.3.272.3.27composer require symfony/http-foundation:^2.3.27
🐘Packagistsymfony/http-foundation≥ 2.4.0&&< 2.5.112.5.11composer require symfony/http-foundation:^2.5.11
🐘Packagistsymfony/http-foundation≥ 2.6.0&&< 2.6.62.6.6composer require symfony/http-foundation:^2.6.6
🐘Packagistsymfony/symfony≥ 2.0.0&&< 2.3.272.3.27composer require symfony/symfony:^2.3.27
🐘Packagistsymfony/symfony≥ 2.4.0&&< 2.5.112.5.11composer require symfony/symfony:^2.5.11
🐘Packagistsymfony/symfony≥ 2.6.0&&< 2.6.62.6.6composer require symfony/symfony:^2.6.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/http-foundation, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symfony/http-foundation to 2.3.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-2309 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, 2.5.X, and 2.6.X versions of the Symfony HttpFoundation component are affected by this security issue. This issue has been fixed in Symfony 2.3.27, 2.5.11, and 2.6.6. Note that no fixes are provided for Symfony 2.0, 2.1, 2.2, and 2.4 as they are not maintained anymore. ### Description The Symfony\Component\HttpFoundation\Request class provides a mechanism that ensures it does not trust HTTP header values coming from a "non-trusted" client. Unfortunately, it assumes that the remote address is always a trusted client if at least one trusted proxy is invol
O3 Security · Impact-Aware SCA

Is CVE-2015-2309 in your dependencies?

Find it across Packagist, including transitive dependencies.