NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2014-5244 — http-foundation

HIGHFix: symfony/symfony#11828

CVE-2014-5244 is a high-severity (CVSS 7.5) vulnerability in symfony/http-foundation. A fix is available for symfony/http-foundation — see the affected versions and patch details below.

Symfony vulnerable to denial of service via a malicious HTTP Host header

Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of May 30, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

6 pkgs affected
🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/http-foundation🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, and 2.5.X versions of the Symfony HttpFoundation component are affected by this security issue.

This issue has been fixed in Symfony 2.3.19, 2.4.9, and 2.5.4. Note that no fixes are provided for Symfony 2.0, 2.1, and 2.2 as they are not maintained anymore.

Description When an arbitrarily long hostname is sent by a client, its parsing in Request::getHost() can lead to a DoS attack, due to the way we validate the hostname via a regular expression.

Resolution The regular expression used to parse and validate the hostname from the HTTP request has been modified to avoid too much sensitivity to the submitted value length.

The patch for this issue is available here: https://github.com/symfony/symfony/pull/11828

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymfony/http-foundation≥ 2.0.0&&< 2.3.192.3.19composer require symfony/http-foundation:^2.3.19
🐘Packagistsymfony/http-foundation≥ 2.4.0&&< 2.4.92.4.9composer require symfony/http-foundation:^2.4.9
🐘Packagistsymfony/http-foundation≥ 2.5.0&&< 2.5.42.5.4composer require symfony/http-foundation:^2.5.4
🐘Packagistsymfony/symfony≥ 2.0.0&&< 2.3.192.3.19composer require symfony/symfony:^2.3.19
🐘Packagistsymfony/symfony≥ 2.4.0&&< 2.4.92.4.9composer require symfony/symfony:^2.4.9
🐘Packagistsymfony/symfony≥ 2.5.0&&< 2.5.42.5.4composer require symfony/symfony:^2.5.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/http-foundation, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symfony/http-foundation to 2.3.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-5244 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, and 2.5.X versions of the Symfony HttpFoundation component are affected by this security issue. This issue has been fixed in Symfony 2.3.19, 2.4.9, and 2.5.4. Note that no fixes are provided for Symfony 2.0, 2.1, and 2.2 as they are not maintained anymore. Description When an arbitrarily long hostname is sent by a client, its parsing in `Request::getHost()` can lead to a DoS attack, due to the way we validate the hostname via a regular expression. Resolution The regular expression used to parse and validate the hostname from the HTTP request has been m
O3 Security · Impact-Aware SCA

Is CVE-2014-5244 in your dependencies?

Find it across Packagist, including transitive dependencies.