NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2018-13796 — mailman

MEDIUM

CVE-2018-13796 is a medium-severity (CVSS 6.5) Improper Input Validation vulnerability in mailman. A fix is available for mailman — see the affected versions and patch details below.

Moderate severity vulnerability that affects mailman

Also known asPYSEC-2026-661
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%1.05%2.10%3.15%0.5%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mailman

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in GNU Mailman before 2.1.28. A crafted URL can cause arbitrary text to be displayed on a web page from a trusted site.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImailmanall versions2.1.28pip install --upgrade 'mailman==2.1.28'

Affected Products

1 product · 1 configurations
Application
mailmangnu
< 2.1.28
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mailman, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mailman to 2.1.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-13796 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 7mailman-3:2.1.15-30.el7RHSA-2020:1054
UbuntuMEDIUM

Frequently Asked Questions

An issue was discovered in GNU Mailman before 2.1.28. A crafted URL can cause arbitrary text to be displayed on a web page from a trusted site.
O3 Security · Impact-Aware SCA

Is CVE-2018-13796 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-13796: mailman — Fixed in 2.1.28