CVE-2004-1177 — mailman
CVE-2004-1177 is a security vulnerability in mailman. A fix is available for mailman — see the affected versions and patch details below.
mailman Cross-site scripting (XSS) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
mailmanReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | mailman | all versions | 2.1.5pip install --upgrade 'mailman==2.1.5' |
Affected Products
mailmangnuDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mailman, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mailman to 2.1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2004-1177 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue did not affect the versions of mailman shipped with Red Hat Enterprise Linux 2.1, 3, or 4. In addition, we believe this issue does not apply to the 2.0.x versions of mailman due to setting of STEALTH_MODE
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 3 | mailman-3:2.1.5-25.rhel3 | RHSA-2005:235 |
Frequently Asked Questions
Is CVE-2004-1177 in your dependencies?
Find it across PyPI, including transitive dependencies.