NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2003-0038 — mailman

CVE-2003-0038 is a security vulnerability in mailman. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for mailman — see the affected versions and patch details below.

Mailman Cross-site scripting (XSS) vulnerability

Also known asPYSEC-2026-657
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
2.95%6.10%9.25%12.4%10.6%4.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍mailman

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImailmanall versions2.1.1pip install --upgrade 'mailman==2.1.1'

Affected Products

1 product · 1 configurations
Application
mailmangnu
1 version
2.1
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-22199webappscgi✓ Verified

GNU Mailman 2.1 - Error Page Cross-Site Scripting

by [email protected] · Jan 24, 2003

EDB-22198webappscgi✓ Verified

GNU Mailman 2.1 - 'email' Cross-Site Scripting

by [email protected] · Jan 24, 2003

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mailman, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mailman to 2.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2003-0038 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.
O3 Security · Impact-Aware SCA

Is CVE-2003-0038 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2003-0038: mailman XSS — Fixed in 2.1.1