NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1190 — cloudfoundry-identity-ser…

MEDIUMFix: cloudfoundry/uaa@96fe267

CVE-2018-1190 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.cloudfoundry.identity:cloudfoundry-identity-server. A fix is available for org.cloudfoundry.identity:cloudfoundry-identity-server — see the affected versions and patch details below.

Pivotal Cloud Foundry UAA XSS on UAA OpenID Connect check session iframe endpoint

Also known asGHSA-j97q-9xp9-g5fx
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.89%1.33%0.2%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.cloudfoundry.identity:cloudfoundry-identity-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in these Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0. A cross-site scripting (XSS) attack is possible in the clientId parameter of a request to the UAA OpenID Connect check session iframe endpoint used for single logout session management.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.0.0&&< 3.20.23.20.2org.cloudfoundry.identity:cloudfoundry-identity-server:3.20.2

Affected Products

3 products · 3 configurations
Application
cf-releasecloudfoundry
≤ 269
range
Application
uaapivotal
≥ 3.0.0 && ≤ 3.20.1
range
Application
uaa boshpivotal
≤ 44
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.cloudfoundry.identity:cloudfoundry-identity-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.cloudfoundry.identity:cloudfoundry-identity-server to 3.20.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1190 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in these Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0. A cross-site scripting (XSS) attack is possible in the clientId parameter of a request to the UAA OpenID Connect check session iframe endpoint used for single logout session management.
O3 Security · Impact-Aware SCA

Is CVE-2018-1190 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1190: cloudfoundry-identity — Fixed in 3.20.2