NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-8032 — cloudfoundry-identity-ser…

MEDIUMFix: cloudfoundry/uaa@2c10c43

CVE-2017-8032 is a medium-severity (CVSS 6.6) Improper Privilege Management vulnerability in org.cloudfoundry.identity:cloudfoundry-identity-server. A fix is available for org.cloudfoundry.identity:cloudfoundry-identity-server — see the affected versions and patch details below.

Cloud Foundry UAA Identity Zone Admin Privilege Escalation

Also known asGHSA-9frw-wmvq-5rrc
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.38%0.3%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Cloud Foundry cf-release versions prior to v264; UAA release all versions of UAA v2.x.x, 3.6.x versions prior to v3.6.13, 3.9.x versions prior to v3.9.15, 3.20.x versions prior to v3.20.0, and other versions prior to v4.4.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.17, 24.x versions prior to v24.12. 30.x versions prior to 30.5, and other versions prior to v41, zone administrators are allowed to escalate their privileges when mapping permissions for an external provider.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-serverall versions3.6.13org.cloudfoundry.identity:cloudfoundry-identity-server:3.6.13
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.7.0&&< 3.9.153.9.15org.cloudfoundry.identity:cloudfoundry-identity-server:3.9.15
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.10.0&&< 3.20.03.20.0org.cloudfoundry.identity:cloudfoundry-identity-server:3.20.0
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 4.0.0&&< 4.4.04.4.0org.cloudfoundry.identity:cloudfoundry-identity-server:4.4.0

Affected Products

3 products · 81 configurations
Application
cloud foundry uaa boshcloudfoundry
≤ 40
33 versions
13.113.213.313.413.513.613.713.813.913.1013.1113.12
Application
cloud foundry cfpivotal_software
≤ 263
range
Application
cloud foundry uaapivotal_software
46 versions
2.2.5.42.7.12.7.22.7.32.7.42.7.4.12.7.4.22.7.4.32.7.4.42.7.4.52.7.4.62.7.4.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.cloudfoundry.identity:cloudfoundry-identity-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.cloudfoundry.identity:cloudfoundry-identity-server to 3.6.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-8032 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

In Cloud Foundry cf-release versions prior to v264; UAA release all versions of UAA v2.x.x, 3.6.x versions prior to v3.6.13, 3.9.x versions prior to v3.9.15, 3.20.x versions prior to v3.20.0, and other versions prior to v4.4.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.17, 24.x versions prior to v24.12. 30.x versions prior to 30.5, and other versions prior to v41, zone administrators are allowed to escalate their privileges when mapping permissions for an external provider.
O3 Security · Impact-Aware SCA

Is CVE-2017-8032 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-8032: cloudfoundry-identity — Fixed in 3.6.13