NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2016-6637 — cloudfoundry-identity-ser…

CRITICALFix: cloudfoundry/uaa@37e0384

CVE-2016-6637 is a critical-severity (CVSS 9.6) Cross-Site Request Forgery (CSRF) vulnerability in org.cloudfoundry.identity:cloudfoundry-identity-server. A fix is available for org.cloudfoundry.identity:cloudfoundry-identity-server — see the affected versions and patch details below.

Cloud Foundry vulnerable to Cross-Site Request Forgery

Also known asGHSA-4m8c-h7fr-gq5c
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.1%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before 3.3.0.5, and 3.4.x before 3.4.4; UAA BOSH before 11.5 and 12.x before 12.5; Elastic Runtime before 1.6.40, 1.7.x before 1.7.21, and 1.8.x before 1.8.2; and Ops Manager 1.7.x before 1.7.13 and 1.8.x before 1.8.1 allow remote attackers to hijack the authentication of unspecified victims for requests that approve or deny a scope via a profile or authorize approval page.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 2.0.0&&< 2.7.4.72.7.4.7org.cloudfoundry.identity:cloudfoundry-identity-server:2.7.4.7
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.0.0&&< 3.3.0.53.3.0.5org.cloudfoundry.identity:cloudfoundry-identity-server:3.3.0.5
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.4.0&&< 3.4.43.4.4org.cloudfoundry.identity:cloudfoundry-identity-server:3.4.4
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.5.0&&< 3.7.03.7.0org.cloudfoundry.identity:cloudfoundry-identity-server:3.7.0

Affected Products

5 products · 97 configurations
Application
cloud foundry uaa boshcloudfoundry
≤ 15.0
range
Application
cloud foundrypivotal_software
≤ 241
range
Application
cloud foundry elastic runtimepivotal_software
60 versions
1.6.01.6.11.6.21.6.31.6.41.6.51.6.61.6.71.6.81.6.91.6.101.6.11
Application
cloud foundry ops managerpivotal_software
14 versions
1.7.01.7.11.7.21.7.31.7.41.7.51.7.61.7.71.7.81.7.91.7.101.7.11
Application
cloud foundry uaapivotal_software
21 versions
2.3.02.3.12.4.02.5.12.6.12.7.0.22.7.0.32.7.12.7.22.7.32.7.4.63.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.cloudfoundry.identity:cloudfoundry-identity-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.cloudfoundry.identity:cloudfoundry-identity-server to 2.7.4.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6637 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before 3.3.0.5, and 3.4.x before 3.4.4; UAA BOSH before 11.5 and 12.x before 12.5; Elastic Runtime before 1.6.40, 1.7.x before 1.7.21, and 1.8.x before 1.8.2; and Ops Manager 1.7.x before 1.7.13 and 1.8.x before 1.8.1 allow remote attackers to hijack the authentication of unspecified victims for requests that approve or deny a scope via a profile or authorize approval page.
O3 Security · Impact-Aware SCA

Is CVE-2016-6637 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-6637: cloudfoundry-identity — Fixed in 2.7.4.7