NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-11047 — cloudfoundry-identity-ser…

HIGHFix: cloudfoundry/uaa@0cd3c6f

CVE-2018-11047 is a high-severity (CVSS 7.5) CWE-863 vulnerability in org.cloudfoundry.identity:cloudfoundry-identity-server. A fix is available for org.cloudfoundry.identity:cloudfoundry-identity-server — see the affected versions and patch details below.

Cloud Foundry UAA accepts refresh token as access token on admin endpoints

Also known asGHSA-r4v8-9hgx-vm6m
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.04%1.57%0.2%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cloud Foundry UAA, versions 4.19 prior to 4.19.2 and 4.12 prior to 4.12.4 and 4.10 prior to 4.10.2 and 4.7 prior to 4.7.6 and 4.5 prior to 4.5.7, incorrectly authorizes requests to admin endpoints by accepting a valid refresh token in lieu of an access token. Refresh tokens by design have a longer expiration time than access tokens, allowing the possessor of a refresh token to authenticate longer than expected. This affects the administrative endpoints of the UAA. i.e. /Users, /Groups, etc. However, if the user has been deleted or had groups removed, or the client was deleted, the refresh token will no longer be valid.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-serverall versions4.5.7org.cloudfoundry.identity:cloudfoundry-identity-server:4.5.7
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 4.6.0&&< 4.7.64.7.6org.cloudfoundry.identity:cloudfoundry-identity-server:4.7.6
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 4.8.0&&< 4.10.24.10.2org.cloudfoundry.identity:cloudfoundry-identity-server:4.10.2
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 4.11.0&&< 4.12.44.12.4org.cloudfoundry.identity:cloudfoundry-identity-server:4.12.4
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 4.13.0&&< 4.19.24.19.2org.cloudfoundry.identity:cloudfoundry-identity-server:4.19.2

Affected Products

1 product · 5 configurations
Application
cloud foundry uaapivotal_software
≥ 4.19.0 && < 4.19.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.cloudfoundry.identity:cloudfoundry-identity-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.cloudfoundry.identity:cloudfoundry-identity-server to 4.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-11047 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Cloud Foundry UAA, versions 4.19 prior to 4.19.2 and 4.12 prior to 4.12.4 and 4.10 prior to 4.10.2 and 4.7 prior to 4.7.6 and 4.5 prior to 4.5.7, incorrectly authorizes requests to admin endpoints by accepting a valid refresh token in lieu of an access token. Refresh tokens by design have a longer expiration time than access tokens, allowing the possessor of a refresh token to authenticate longer than expected. This affects the administrative endpoints of the UAA. i.e. /Users, /Groups, etc. However, if the user has been deleted or had groups removed, or the client was deleted, the refresh toke
O3 Security · Impact-Aware SCA

Is CVE-2018-11047 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-11047: cloudfoundry-identity — Fixed in 4.5.7