NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1067 — wildfly-undertow

MEDIUM

CVE-2018-1067 is a medium-severity (CVSS 6.1) CWE-113 vulnerability in org.jboss.eap:wildfly-undertow. A fix is available for org.jboss.eap:wildfly-undertow — see the affected versions and patch details below.

Improper Neutralization of CRLF Sequences in HTTP Headers in Undertow

Also known asGHSA-47mp-rq2x-wjf2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.13%0.86%1.59%2.32%0.6%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jboss.eap:wildfly-undertow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Undertow before versions 7.1.2.CR1, 7.1.2.GA it was found that the fix for CVE-2016-4993 was incomplete and Undertow web server is vulnerable to the injection of arbitrary HTTP headers, and also response splitting, due to insufficient sanitization and validation of user input before the input is used as part of an HTTP header value.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jboss.eap:wildfly-undertowall versions7.1.2.GAorg.jboss.eap:wildfly-undertow:7.1.2.GA

Affected Products

3 products · 4 configurations
Application
jboss enterprise application platformredhat
1 version
7.1
Application
undertowredhat
≥ 2.0.0 && < 2.0.5
range
Application
virtualization hostredhat
1 version
4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.eap:wildfly-undertow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jboss.eap:wildfly-undertow to 7.1.2.GA or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1067 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat JBoss EAP 7.1see advisoryRHSA-2018:1251
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6eap7-activemq-artemis-0:1.5.5.010-1.redhat_1.1.ep7.el6RHSA-2018:1248
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6eap7-jboss-ec2-eap-0:7.1.2-1.GA_redhat_1.ep7.el6RHSA-2018:1249
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 7eap7-activemq-artemis-0:1.5.5.010-1.redhat_1.1.ep7.el7RHSA-2018:1247
Red Hat JBoss Enterprise Application Platform Continuous DeliveryundertowRHSA-2020:2562
Red Hat Virtualization 4 for Red Hat Enterprise Linux 7rhvm-appliance-0:4.2-20180828.0.el7RHSA-2018:2643
Text-Only RHOARsee advisoryRHSA-2019:0877

Frequently Asked Questions

In Undertow before versions 7.1.2.CR1, 7.1.2.GA it was found that the fix for CVE-2016-4993 was incomplete and Undertow web server is vulnerable to the injection of arbitrary HTTP headers, and also response splitting, due to insufficient sanitization and validation of user input before the input is used as part of an HTTP header value.
O3 Security · Impact-Aware SCA

Is CVE-2018-1067 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1067: wildfly-undertow — Fixed in 7.1.2.GA