NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-1048 — wildfly-undertow

HIGH

CVE-2018-1048 is a high-severity (CVSS 7.5) Path Traversal vulnerability in org.jboss.eap:wildfly-undertow. A fix is available for org.jboss.eap:wildfly-undertow — see the affected versions and patch details below.

Improper Limitation of a Pathname to a Restricted Directory in Jboss EAP Undertow

Also known asGHSA-prfw-3qx6-g9xr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.01%0.71%1.40%2.10%0.5%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jboss.eap:wildfly-undertow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

It was found that the AJP connector in undertow, as shipped in Jboss EAP 7.1.0.GA, does not use the ALLOW_ENCODED_SLASH option and thus allow the the slash / anti-slash characters encoded in the url which may lead to path traversal and result in the information disclosure of arbitrary local files.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jboss.eap:wildfly-undertow≥ 7.1.0.GA&&< 7.1.1.GA7.1.1.GAorg.jboss.eap:wildfly-undertow:7.1.1.GA

Affected Products

1 product · 1 configurations
Application
jboss enterprise application platformredhat
1 version
7.1.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.eap:wildfly-undertow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jboss.eap:wildfly-undertow to 7.1.1.GA or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1048 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat JBoss EAP 7undertowRHSA-2018:0478
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6eap7-activemq-artemis-0:1.5.5.009-1.redhat_1.1.ep7.el6RHSA-2018:0479
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6eap7-jboss-ec2-eap-0:7.1.1-3.1.GA_redhat_3.ep7.el6RHSA-2018:0481
Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 7eap7-activemq-artemis-0:1.5.5.009-1.redhat_1.1.ep7.el7RHSA-2018:0480

Frequently Asked Questions

It was found that the AJP connector in undertow, as shipped in Jboss EAP 7.1.0.GA, does not use the ALLOW_ENCODED_SLASH option and thus allow the the slash / anti-slash characters encoded in the url which may lead to path traversal and result in the information disclosure of arbitrary local files.
O3 Security · Impact-Aware SCA

Is CVE-2018-1048 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1048: wildfly Path Traversal — Fixed in 7.1.1.GA