NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2018-10188 — phpmyadmin

HIGHFix: phpmyadmin/phpmyadmin@c6dd6b5

CVE-2018-10188 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in phpmyadmin/phpmyadmin. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution

Also known asGHSA-v6fp-h79x-9rqc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.00%1.76%3.53%5.29%0.9%4.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.8&&< 4.8.0.14.8.0.1composer require phpmyadmin/phpmyadmin:^4.8.0.1

Affected Products

1 product · 1 configurations
Application
phpmyadminphpmyadmin
1 version
4.8.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-44496webappsphp

phpMyAdmin 4.8.0 < 4.8.0-1 - Cross-Site Request Forgery

by revengsh · Apr 23, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.8.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-10188 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.
O3 Security · Impact-Aware SCA

Is CVE-2018-10188 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-10188: phpmyadmin CSRF — Fixed in 4.8.0.1