NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-1000130 — jolokia-core

HIGHFix: rhuss/jolokia@1b360b8

CVE-2018-1000130 is a high-severity (CVSS 8.1) CWE-74 vulnerability in org.jolokia:jolokia-core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.jolokia:jolokia-core — see the affected versions and patch details below.

Injection in Jolokia agent

Also known asGHSA-rhqj-4pp8-vvgf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
73.7%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
67.2%77.0%86.8%96.6%91.1%73.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jolokia:jolokia-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A JNDI Injection vulnerability exists in Jolokia agent version 1.3.7 in the proxy mode that allows a remote attacker to run arbitrary Java code on the server.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jolokia:jolokia-core≥ 1.3.7&&< 1.5.01.5.0org.jolokia:jolokia-core:1.5.0

Affected Products

1 product · 1 configurations
Application
webarchive agentjolokia
1 version
1.3.7
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jolokia:jolokia-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jolokia:jolokia-core to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000130 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2018-1000130

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2018-1000130 -u https://target
Template
Jolokia Agent - JNDI Code Injection
Severity
high
Impact
Successful exploitation of this vulnerability can lead to remote code execution, compromising the affected system.
Remediation
Apply the latest security patches or updates provided by the vendor to fix the vulnerability.

Template by ProjectDiscovery nuclei-templates (milo2012), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

For Red Hat OpenStack Platform, although the affected code is present in shipped packages, proxy mode is not enabled by default and the affected code is not used in any supported configuration of Red Hat OpenStack Platform. For this reason, the RHOSP impact as been reduced to Low and this issue is not currently…

ProductFixed inAdvisory
Red Hat Fuse 7jolokia-coreRHSA-2018:2669

Frequently Asked Questions

A JNDI Injection vulnerability exists in Jolokia agent version 1.3.7 in the proxy mode that allows a remote attacker to run arbitrary Java code on the server.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000130 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000130: jolokia-core — Fixed in 1.5.0