NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-0168 — jolokia-core

Fix: rhuss/jolokia@2d9b168

CVE-2014-0168 is a Cross-Site Request Forgery (CSRF) vulnerability in org.jolokia:jolokia-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.jolokia:jolokia-core — see the affected versions and patch details below.

Cross-Site Request Forgery in Jolokia

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.41%0.83%1.24%0.1%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.jolokia:jolokia-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site request forgery (CSRF) vulnerability in Jolokia before 1.2.1 allows remote attackers to hijack the authentication of users for requests that execute MBeans methods via a crafted web page.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jolokia:jolokia-coreall versions1.2.1org.jolokia:jolokia-core:1.2.1

Affected Products

1 product · 14 configurations
Application
jolokiajolokia
≤ 1.2.0
13 versions
1.0.01.0.11.0.21.0.31.0.41.0.51.0.61.1.01.1.11.1.21.1.31.1.4
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jolokia:jolokia-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jolokia:jolokia-core to 1.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0168 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Cross-site request forgery (CSRF) vulnerability in Jolokia before 1.2.1 allows remote attackers to hijack the authentication of users for requests that execute MBeans methods via a crafted web page.
O3 Security · Impact-Aware SCA

Is CVE-2014-0168 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-0168: jolokia-core CSRF — Fixed in 1.2.1