NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1000129 — jolokia-core

MEDIUMFix: rhuss/jolokia@5895d5c

CVE-2018-1000129 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.jolokia:jolokia-core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.jolokia:jolokia-core — see the affected versions and patch details below.

Cross-site Scripting in Jolokia agent

Also known asGHSA-hfpg-gqjw-779m
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
24.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
9.04%36.8%64.6%92.4%76.8%24.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jolokia:jolokia-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An XSS vulnerability exists in the Jolokia agent version 1.3.7 in the HTTP servlet that allows an attacker to execute malicious javascript in the victim's browser.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jolokia:jolokia-core≥ 1.3.7&&< 1.5.01.5.0org.jolokia:jolokia-core:1.5.0

Affected Products

1 product · 1 configurations
Application
jolokiajolokia
1 version
1.3.7
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jolokia:jolokia-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jolokia:jolokia-core to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000129 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2018-1000129

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2018-1000129 -u https://target
Template
Jolokia 1.3.7 - Cross-Site Scripting
Severity
medium
Impact
Successful exploitation of this vulnerability could allow an attacker to execute arbitrary JavaScript code in the victim's browser, leading to session hijacking, defacement, or theft of sensitive information.
Remediation
Upgrade to a patched version of Jolokia or apply the necessary security patches to mitigate the XSS vulnerability.

Template by ProjectDiscovery nuclei-templates (mavericknerd, 0h1in9e, daffainfo), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Product Security has rated this issue as having security impact of Low for: * Red Hat OpenStack Platform 9.0 (Mitaka) * Red Hat OpenStack Platform 10.0 (Newton) * Red Hat OpenStack Platform 11.0 (Ocata) * Red Hat OpenStack Platform 12.0 (Pike) Although the affected code is present in shipped packages, data…

ProductFixed inAdvisory
Red Hat Fuse 7jolokia-coreRHSA-2018:2669
Red Hat JBoss A-MQ 6.3jolokia-coreRHSA-2018:3817

Frequently Asked Questions

An XSS vulnerability exists in the Jolokia agent version 1.3.7 in the HTTP servlet that allows an attacker to execute malicious javascript in the victim's browser.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000129 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000129: jolokia-core XSS — Fixed in 1.5.0