NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2018-1000075 — jruby-stdlib

HIGHFix: rubygems/rubygems@92e98bf

CVE-2018-1000075 is a high-severity (CVSS 7.5) CWE-835 vulnerability in org.jruby:jruby-stdlib. A fix is available for org.jruby:jruby-stdlib — see the affected versions and patch details below.

RubyGems Infinite Loop vulnerability

Also known asGHSA-74pv-v9gh-h25p
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.85%2.47%4.10%5.72%1.8%4.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jruby:jruby-stdlib💎rubygems-update

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jruby:jruby-stdliball versions9.1.16.0org.jruby:jruby-stdlib:9.1.16.0
💎RubyGemsrubygems-updateall versions2.7.6bundle update rubygems-update --conservative

Affected Products

2 products · 5 configurations
OS
debian linuxdebian
1 version
7.0
Application
rubygemsrubygems
≤ 2.5.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jruby:jruby-stdlib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jruby:jruby-stdlib to 9.1.16.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000075 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

This issue affects the versions of rubygems as shipped with Red Hat Subscription Asset Manager 1.x. Red Hat Product Security has rated this issue as having security impact of Low. A future update may address this issue. For additional information, refer to the Issue Severity Classification:…

ProductFixed inAdvisory
Red Hat Enterprise Linux 7ruby-0:2.0.0.648-36.el7RHSA-2019:2028
Red Hat Enterprise Linux 7.4 Advanced Update Supportruby-0:2.0.0.648-35.el7_4RHSA-2020:0591
Red Hat Enterprise Linux 7.5 Extended Update Supportruby-0:2.0.0.648-35.el7_5RHSA-2020:0542
Red Hat Enterprise Linux 7.6 Extended Update Supportruby-0:2.0.0.648-36.el7_6RHSA-2020:0663
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby23-ruby-0:2.3.8-69.el6RHSA-2018:3729
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby24-ruby-0:2.4.5-91.el6RHSA-2018:3730
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-ruby25-ruby-0:2.5.3-6.el7RHSA-2018:3731

Frequently Asked Questions

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000075 in your dependencies?

Find it across Maven, RubyGems, including transitive dependencies.

CVE-2018-1000075: jruby-stdlib — Fixed in 9.1.16.0