CVE-2018-1000074 is a high-severity (CVSS 7.8) Deserialization of Untrusted Data vulnerability in org.jruby:jruby-stdlib. A fix is available for org.jruby:jruby-stdlib — see the affected versions and patch details below.
RubyGems Deserialization of Untrusted Data vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jruby:jruby-stdlib💎rubygems-updateReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the gem owner command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jruby:jruby-stdlib | all versions | 9.1.16.0org.jruby:jruby-stdlib:9.1.16.0 |
| 💎RubyGems | rubygems-update | all versions | 2.7.6bundle update rubygems-update --conservative |
Affected Products
rubygemsrubygemsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jruby:jruby-stdlib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jruby:jruby-stdlib to 9.1.16.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000074 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue affects the versions of rubygems as shipped with Red Hat Subscription Asset Manager 1.x. Red Hat Product Security has rated this issue as having security impact of Moderate. A future update may address this issue. For additional information, refer to the Issue Severity Classification:…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | ruby-0:2.0.0.648-36.el7 | RHSA-2019:2028 |
| Red Hat Enterprise Linux 7.4 Advanced Update Support | ruby-0:2.0.0.648-35.el7_4 | RHSA-2020:0591 |
| Red Hat Enterprise Linux 7.5 Extended Update Support | ruby-0:2.0.0.648-35.el7_5 | RHSA-2020:0542 |
| Red Hat Enterprise Linux 7.6 Extended Update Support | ruby-0:2.0.0.648-36.el7_6 | RHSA-2020:0663 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby23-ruby-0:2.3.8-69.el6 | RHSA-2018:3729 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby24-ruby-0:2.4.5-91.el6 | RHSA-2018:3730 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-ruby25-ruby-0:2.5.3-6.el7 | RHSA-2018:3731 |
Frequently Asked Questions
Is CVE-2018-1000074 in your dependencies?
Find it across Maven, RubyGems, including transitive dependencies.