NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-8031 — cloudfoundry-identity-ser…

MEDIUMFix: cloudfoundry/uaa@1e2a746

CVE-2017-8031 is a medium-severity (CVSS 5.3) vulnerability in org.cloudfoundry.identity:cloudfoundry-identity-server. A fix is available for org.cloudfoundry.identity:cloudfoundry-identity-server — see the affected versions and patch details below.

Cloud Foundry UAA Denial of Service through client token revocation endpoint

Also known asGHSA-j4p3-2m2h-cv5f
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.53%1.06%1.59%0.4%1.1%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Cloud Foundry Foundation cf-release (all versions prior to v279) and UAA (30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1). In some cases, the UAA allows an authenticated user for a particular client to revoke client tokens for other users on the same client. This occurs only if the client is using opaque tokens or JWT tokens validated using the check_token endpoint. A malicious actor could cause denial of service.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 4.6.0&&< 4.7.14.7.1org.cloudfoundry.identity:cloudfoundry-identity-server:4.7.1
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 4.0.0&&< 4.5.34.5.3org.cloudfoundry.identity:cloudfoundry-identity-server:4.5.3
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-serverall versions3.20.1org.cloudfoundry.identity:cloudfoundry-identity-server:3.20.1

Affected Products

2 products · 4 configurations
Application
cf-releasecloudfoundry
≤ 278
range
Application
uaa-releasecloudfoundry
≥ 45 && < 45.4
1 version
52

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.cloudfoundry.identity:cloudfoundry-identity-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.cloudfoundry.identity:cloudfoundry-identity-server to 4.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-8031 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

An issue was discovered in Cloud Foundry Foundation cf-release (all versions prior to v279) and UAA (30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1). In some cases, the UAA allows an authenticated user for a particular client to revoke client tokens for other users on the same client. This occurs only if the client is using opaque tokens or JWT tokens validated using the check_token endpoint. A malicious actor could cause denial of service.
O3 Security · Impact-Aware SCA

Is CVE-2017-8031 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-8031: cloudfoundry-identity DoS — Fixed in 4.7.1