NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2017-7214 — nova

CRITICALFix: openstack/nova@3f985f1

CVE-2017-7214 is a critical-severity (CVSS 9.8) CWE-532 vulnerability in nova. A fix is available for nova — see the affected versions and patch details below.

OpenStack Nova logs sensitive context from notification exceptions

Also known asGHSA-f4g4-cj8f-3cr9PYSEC-2026-432
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.80%1.47%2.13%2.80%1.3%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍nova🐍nova🐍nova

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in exception_wrapper.py in OpenStack Nova 13.x through 13.1.3, 14.x through 14.0.4, and 15.x through 15.0.1. Legacy notification exception contexts appearing in ERROR level logs may include sensitive information such as account passwords and authorization tokens.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInova≥ 13.0.0&&< 13.1.413.1.4pip install --upgrade 'nova==13.1.4'
🐍PyPInova≥ 14.0.0&&< 14.0.514.0.5pip install --upgrade 'nova==14.0.5'
🐍PyPInova≥ 15.0.1&&< 15.0.215.0.2pip install --upgrade 'nova==15.0.2'

Affected Products

1 product · 12 configurations
Application
novaopenstack
12 versions
13.0.013.1.013.1.113.1.213.1.314.0.014.0.114.0.214.0.314.0.415.0.015.0.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nova to 13.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7214 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenStack Platform 10.0 (Newton)openstack-nova-1:14.0.6-2.el7ostRHSA-2017:1595
Red Hat OpenStack Platform 9.0 (Mitaka)openstack-nova-1:13.1.4-1.el7ostRHSA-2017:1508

Frequently Asked Questions

An issue was discovered in exception_wrapper.py in OpenStack Nova 13.x through 13.1.3, 14.x through 14.0.4, and 15.x through 15.0.1. Legacy notification exception contexts appearing in ERROR level logs may include sensitive information such as account passwords and authorization tokens.
O3 Security · Impact-Aware SCA

Is CVE-2017-7214 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-7214: nova — Fixed in 13.1.4