CVE-2017-5648 is a critical-severity (CVSS 9.1) CWE-668 vulnerability in org.apache.tomcat:tomcat-catalina. EPSS puts its 30-day exploitation probability at 13.2% (96th percentile). A fix is available for org.apache.tomcat:tomcat-catalina — see the affected versions and patch details below.
Exposure of Resource to Wrong Sphere in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2017-5648.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
While investigating bug 60718, it was noticed that some calls to application listeners in Apache Tomcat 9.0.0.M1 to 9.0.0.M17, 8.5.0 to 8.5.11, 8.0.0.RC1 to 8.0.41, and 7.0.0 to 7.0.75 did not use the appropriate facade object. When running an untrusted application under a SecurityManager, it was therefore possible for that untrusted application to retain a reference to the request or response object and thereby access and/or modify information associated with another web application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 9.0.0.M1&&< 9.0.0.M18 | 9.0.0.M18org.apache.tomcat:tomcat-catalina:9.0.0.M18 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 8.5.0&&< 8.5.13 | 8.5.13org.apache.tomcat:tomcat-catalina:8.5.13 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 8.0.0&&< 8.0.42 | 8.0.42org.apache.tomcat:tomcat-catalina:8.0.42 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 7.0.0&&< 7.0.76 | 7.0.76org.apache.tomcat:tomcat-catalina:7.0.76 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.0.M1&&< 9.0.0.M18 | 9.0.0.M18org.apache.tomcat.embed:tomcat-embed-core:9.0.0.M18 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 8.5.0&&< 8.5.13 | 8.5.13org.apache.tomcat.embed:tomcat-embed-core:8.5.13 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-catalina, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-catalina to 9.0.0.M18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5648 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.69-12.el7_3 | RHSA-2017:1809 |
| Red Hat JBoss Web Server 3.1 | see advisory | RHSA-2017:1802 |
| Red Hat JBoss Web Server 3 for RHEL 6 | log4j-eap6-0:1.2.16-12.redhat_3.1.ep6.el6 | RHSA-2017:1801 |
Frequently Asked Questions
Is CVE-2017-5648 in your dependencies?
Find it across Maven, including transitive dependencies.