NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-4974 — cloudfoundry-identity-ser…

MEDIUMFix: cloudfoundry/uaa@01edea6

CVE-2017-4974 is a medium-severity (CVSS 6.5) SQL Injection vulnerability in org.cloudfoundry.identity:cloudfoundry-identity-server. A fix is available for org.cloudfoundry.identity:cloudfoundry-identity-server — see the affected versions and patch details below.

Blind SQL Injection with privileged Cloud Foundry UAA endpoints

Also known asGHSA-cw9c-v3v2-99hm
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.98%1.47%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v258; UAA release 2.x versions prior to v2.7.4.15, 3.6.x versions prior to v3.6.9, 3.9.x versions prior to v3.9.11, and other versions prior to v3.16.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.13, 24.x versions prior to v24.8, and other versions prior to v30.1. An authorized user can use a blind SQL injection attack to query the contents of the UAA database, aka "Blind SQL Injection with privileged UAA endpoints."

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 2.0.0&&< 2.7.4.152.7.4.15org.cloudfoundry.identity:cloudfoundry-identity-server:2.7.4.15
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.0.0&&< 3.6.93.6.9org.cloudfoundry.identity:cloudfoundry-identity-server:3.6.9
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.7.0&&< 3.9.113.9.11org.cloudfoundry.identity:cloudfoundry-identity-server:3.9.11
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.10.0&&< 3.16.03.16.0org.cloudfoundry.identity:cloudfoundry-identity-server:3.16.0

Affected Products

3 products · 64 configurations
Application
cf-releasecloudfoundry
≤ v257
range
Application
cloud foundry uaa boshcloudfoundry
≤ 30
23 versions
13.113.213.313.413.513.613.713.813.913.1013.1113.12
Application
cloud foundry uaapivotal_software
≤ 4.2.0
38 versions
2.2.5.42.7.12.7.22.7.32.7.42.7.4.12.7.4.22.7.4.32.7.4.42.7.4.52.7.4.62.7.4.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.cloudfoundry.identity:cloudfoundry-identity-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.cloudfoundry.identity:cloudfoundry-identity-server to 2.7.4.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-4974 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v258; UAA release 2.x versions prior to v2.7.4.15, 3.6.x versions prior to v3.6.9, 3.9.x versions prior to v3.9.11, and other versions prior to v3.16.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.13, 24.x versions prior to v24.8, and other versions prior to v30.1. An authorized user can use a blind SQL injection attack to query the contents of the UAA database, aka "Blind SQL Injection with privileged UAA endpoints."
O3 Security · Impact-Aware SCA

Is CVE-2017-4974 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-4974: cloudfoundry-identity — Fixed in 2.7.4.15