NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2017-4973 — cloudfoundry-identity-ser…

HIGHFix: cloudfoundry/uaa@0762cc7

CVE-2017-4973 is a high-severity (CVSS 8.8) Improper Privilege Management vulnerability in org.cloudfoundry.identity:cloudfoundry-identity-server. A fix is available for org.cloudfoundry.identity:cloudfoundry-identity-server — see the affected versions and patch details below.

Cloud Foundry UAA Privilege Escalation

Also known asGHSA-pgjc-gc7g-p2c6
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.05%1.57%0.3%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server☕org.cloudfoundry.identity:cloudfoundry-identity-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v257; UAA release 2.x versions prior to v2.7.4.14, 3.6.x versions prior to v3.6.8, 3.9.x versions prior to v3.9.10, and other versions prior to v3.15.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.12, 24.x versions prior to v24.7, and other versions prior to v30. A vulnerability has been identified with the groups endpoint in UAA allowing users to elevate their privileges.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 2.0.0&&< 2.7.4.142.7.4.14org.cloudfoundry.identity:cloudfoundry-identity-server:2.7.4.14
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.0.0&&< 3.6.83.6.8org.cloudfoundry.identity:cloudfoundry-identity-server:3.6.8
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.7.0&&< 3.9.103.9.10org.cloudfoundry.identity:cloudfoundry-identity-server:3.9.10
☕Mavenorg.cloudfoundry.identity:cloudfoundry-identity-server≥ 3.10.0&&< 3.15.03.15.0org.cloudfoundry.identity:cloudfoundry-identity-server:3.15.0

Affected Products

3 products · 58 configurations
Application
cloud foundry uaa boshcloudfoundry
≤ 30
21 versions
13.113.213.313.413.513.613.713.813.913.1013.1124
Application
cloud foundry cfpivotal_software
≤ 256
range
Application
cloud foundry uaapivotal_software
35 versions
2.2.5.42.7.12.7.22.7.32.7.42.7.4.12.7.4.22.7.4.32.7.4.42.7.4.52.7.4.62.7.4.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.cloudfoundry.identity:cloudfoundry-identity-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.cloudfoundry.identity:cloudfoundry-identity-server to 2.7.4.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-4973 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v257; UAA release 2.x versions prior to v2.7.4.14, 3.6.x versions prior to v3.6.8, 3.9.x versions prior to v3.9.10, and other versions prior to v3.15.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.12, 24.x versions prior to v24.7, and other versions prior to v30. A vulnerability has been identified with the groups endpoint in UAA allowing users to elevate their privileges.
O3 Security · Impact-Aware SCA

Is CVE-2017-4973 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-4973: cloudfoundry-identity — Fixed in 2.7.4.14