NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2017-14506 — geminabox

MEDIUMFix: geminabox/geminabox@99aaae1

CVE-2017-14506 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in geminabox. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for geminabox — see the affected versions and patch details below.

Gem in a Box vulnerable to Cross-site Scripting

Also known asGHSA-98hq-3qvg-pg78
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.39%0.79%1.18%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎geminabox

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

geminabox (aka Gem in a Box) before 0.13.6 is vulnerable to Cross-site Scripting (XSS), as demonstrated by uploading a gem file that has a crafted gem.homepage value in its .gemspec file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsgeminaboxall versions0.13.6bundle update geminabox --conservative

Affected Products

1 product · 1 configurations
Application
geminaboxgeminabox_project
≤ 0.13.5
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for geminabox, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update geminabox to 0.13.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-14506 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

geminabox (aka Gem in a Box) before 0.13.6 is vulnerable to Cross-site Scripting (XSS), as demonstrated by uploading a gem file that has a crafted gem.homepage value in its .gemspec file.
O3 Security · Impact-Aware SCA

Is CVE-2017-14506 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2017-14506: geminabox XSS — Fixed in 0.13.6