NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2017-14683 — geminabox

HIGHFix: geminabox/geminabox@a01c4e8

CVE-2017-14683 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in geminabox. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for geminabox — see the affected versions and patch details below.

Gem in a Box vulnerable to Cross-site Request Forgery

Also known asGHSA-qwv2-2x8g-g43g
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.00%0.33%0.66%1.00%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎geminabox

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

geminabox (aka Gem in a Box) before 0.13.7 has CSRF, as demonstrated by an unintended gem upload.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsgeminaboxall versions0.13.7bundle update geminabox --conservative

Affected Products

1 product · 1 configurations
Application
geminaboxgeminabox_project
≤ 0.13.6
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for geminabox, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update geminabox to 0.13.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-14683 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

geminabox (aka Gem in a Box) before 0.13.7 has CSRF, as demonstrated by an unintended gem upload.
O3 Security · Impact-Aware SCA

Is CVE-2017-14683 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2017-14683: geminabox CSRF — Fixed in 0.13.7