NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2017-11770 — System.Security.Cryptogra…

HIGH

CVE-2017-11770 is a high-severity (CVSS 7.5) CWE-295 vulnerability in System.Security.Cryptography.X509Certificates. A fix is available for System.Security.Cryptography.X509Certificates — see the affected versions and patch details below.

Improper Certificate Validation

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
2.94%7.35%11.8%16.2%13.7%5.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
.NETSystem.Security.Cryptography.X509Certificates.NETMicrosoft.NETCore.App

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

.NET Core 1.0, 1.1, and 2.0 allow an unauthenticated attacker to remotely cause a denial of service attack against a .NET Core web application by improperly parsing certificate data. A denial of service vulnerability exists when .NET Core improperly handles parsing certificate data, aka ".NET CORE Denial Of Service Vulnerability".

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetSystem.Security.Cryptography.X509Certificates≥ 4.0.0&&< 4.1.24.1.2dotnet add package System.Security.Cryptography.X509Certificates --version 4.1.2
.NETNuGetMicrosoft.NETCore.App≥ 1.0.0&&< 2.0.32.0.3dotnet add package Microsoft.NETCore.App --version 2.0.3

Affected Products

1 product · 3 configurations
Application
aspnetcoremicrosoft
3 versions
1.01.12.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for System.Security.Cryptography.X509Certificates, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update System.Security.Cryptography.X509Certificates to 4.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-11770 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
.NET Core on Red Hat Enterprise Linuxrh-dotnet20-dotnet-0:2.0.3-4.el7RHSA-2017:3248

Frequently Asked Questions

.NET Core 1.0, 1.1, and 2.0 allow an unauthenticated attacker to remotely cause a denial of service attack against a .NET Core web application by improperly parsing certificate data. A denial of service vulnerability exists when .NET Core improperly handles parsing certificate data, aka ".NET CORE Denial Of Service Vulnerability".
O3 Security · Impact-Aware SCA

Is CVE-2017-11770 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2017-11770: System.Security DoS — Fixed in 4.1.2