NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2017-8585 — Microsoft.NETCore.App

HIGH

CVE-2017-8585 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in Microsoft.NETCore.App. A fix is available for Microsoft.NETCore.App — see the affected versions and patch details below.

Improper Input Validation in Microsoft.NETCore.App

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
9.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
4.22%13.6%23.0%32.4%27.1%9.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
.NETMicrosoft.NETCore.App.NETMicrosoft.NETCore.App

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Microsoft .NET Framework 4.6, 4.6.1, 4.6.2, and 4.7 allow an attacker to send specially crafted requests to a .NET web application, resulting in denial of service, aka .NET Denial of Service Vulnerability.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMicrosoft.NETCore.App≥ 1.0.0&&< 1.0.71.0.7dotnet add package Microsoft.NETCore.App --version 1.0.7
.NETNuGetMicrosoft.NETCore.App≥ 1.1.0&&< 1.1.41.1.4dotnet add package Microsoft.NETCore.App --version 1.1.4

Affected Products

1 product · 4 configurations
Application
.net frameworkmicrosoft
4 versions
4.64.6.14.6.24.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.NETCore.App, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Microsoft.NETCore.App to 1.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-8585 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
.NET Core on Red Hat Enterprise Linuxrh-dotnet20-dotnet-0:2.0.3-4.el7RHSA-2017:3248

Frequently Asked Questions

Microsoft .NET Framework 4.6, 4.6.1, 4.6.2, and 4.7 allow an attacker to send specially crafted requests to a .NET web application, resulting in denial of service, aka .NET Denial of Service Vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2017-8585 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2017-8585: Microsoft.NETCore DoS — Fixed in 1.0.7