CVE-2019-0657 — Microsoft.NETCore.App
MEDIUMCVE-2019-0657 is a medium-severity (CVSS 5.9) Improper Input Validation vulnerability in Microsoft.NETCore.App. A fix is available for Microsoft.NETCore.App — see the affected versions and patch details below.
Improper Input Validation in .Net Framework API's
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Microsoft.NETCore.App.NETMicrosoft.NETCore.App.NETSystem.Private.UriReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability exists in certain .Net Framework API's and Visual Studio in the way they parse URL's, aka '.NET Framework and Visual Studio Spoofing Vulnerability'.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Microsoft.NETCore.App | ≥ 2.2.0&&< 2.2.2 | 2.2.2dotnet add package Microsoft.NETCore.App --version 2.2.2 |
| .NETNuGet | Microsoft.NETCore.App | ≥ 2.1.0&&< 2.1.8 | 2.1.8dotnet add package Microsoft.NETCore.App --version 2.1.8 |
| .NETNuGet | System.Private.Uri | ≥ 4.3.0&&< 4.3.2 | 4.3.2dotnet add package System.Private.Uri --version 4.3.2 |
Affected Products
.net coremicrosoft.net frameworkmicrosoftpowershell coremicrosoftvisual studio 2017microsoftDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.NETCore.App, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Microsoft.NETCore.App to 2.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-0657 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| .NET Core on Red Hat Enterprise Linux | rh-dotnet21-0:2.1-7.el7 | RHSA-2019:0349 |
Frequently Asked Questions
Is CVE-2019-0657 in your dependencies?
Find it across NuGet, including transitive dependencies.