NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2017-1002102 — kubernetes

MEDIUM

CVE-2017-1002102 is a medium-severity (CVSS 5.6) vulnerability in k8s.io/kubernetes. A fix is available for k8s.io/kubernetes — see the affected versions and patch details below.

Kubernetes arbitrary file overwrite

Also known asGHSA-mm7g-f2gg-cw8gGO-2023-1977
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk+0.04%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.53%1.07%1.60%0.5%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹k8s.io/kubernetes🐹k8s.io/kubernetes🐹k8s.io/kubernetes

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using a secret, configMap, projected or downwardAPI volume can trigger deletion of arbitrary files/directories from the nodes where they are running.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gok8s.io/kubernetes≥ 1.3.0&&< 1.7.141.7.14go get k8s.io/kubernetes@v1.7.14
🐹Gok8s.io/kubernetes≥ 1.8.0&&< 1.8.91.8.9go get k8s.io/kubernetes@v1.8.9
🐹Gok8s.io/kubernetes≥ 1.9.0&&< 1.9.41.9.4go get k8s.io/kubernetes@v1.9.4

Affected Products

1 product · 7 configurations
Application
kuberneteskubernetes
≥ 1.9.0 && ≤ 1.6.13
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for k8s.io/kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update k8s.io/kubernetes to 1.7.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1002102 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.3atomic-openshift-0:3.3.1.46.11-1.git.4.e236015.el7RHSA-2018:0475

Frequently Asked Questions

In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using a secret, configMap, projected or downwardAPI volume can trigger deletion of arbitrary files/directories from the nodes where they are running.
O3 Security · Impact-Aware SCA

Is CVE-2017-1002102 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2017-1002102: kubernetes — Fixed in 1.7.14