NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2017-1000499 — phpmyadmin

HIGH

CVE-2017-1000499 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in phpmyadmin/phpmyadmin. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin CSRF Vulnerability

Also known asGHSA-f9hx-5jq4-fgjm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
7.57%9.16%10.7%12.3%11.4%8.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.7&&< 4.7.74.7.7composer require phpmyadmin/phpmyadmin:^4.7.7

Affected Products

1 product · 1 configurations
Application
phpmyadminphpmyadmin
≥ 4.7.0 && < 4.7.7
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-45284webappsphp✓ Verified

phpMyAdmin 4.7.x - Cross-Site Request Forgery

by VulnSpy · Aug 29, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.7.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000499 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000499 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-1000499: phpmyadmin CSRF — Fixed in 4.7.7