NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2017-1000115 — mercurial

HIGH

CVE-2017-1000115 is a high-severity (CVSS 7.5) CWE-59 vulnerability in mercurial. A fix is available for mercurial — see the affected versions and patch details below.

Mercurial missing symlink check

Also known asGHSA-hvr9-wr9p-grgrPYSEC-2017-88
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
1.34%2.77%4.19%5.62%2.1%4.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mercurial

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImercurialall versions4.3.1pip install --upgrade 'mercurial==4.3.1'

Affected Products

8 products · 13 configurations
OS
debian linuxdebian
2 versions
8.09.0
Application
mercurialmercurial
< 4.3
range
OS
enterprise linux desktopredhat
1 version
7.0
OS
enterprise linux serverredhat
1 version
7.0
OS
enterprise linux server ausredhat
2 versions
7.47.6
OS
enterprise linux server eusredhat
3 versions
7.47.57.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mercurial, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mercurial to 4.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000115 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Enterprise Linux 7mercurial-0:2.6.2-8.el7_4RHSA-2017:2489

Frequently Asked Questions

Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository
O3 Security · Impact-Aware SCA

Is CVE-2017-1000115 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-1000115: mercurial — Fixed in 4.3.1