NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-3630 — mercurial

HIGH

CVE-2016-3630 is a high-severity (CVSS 8.8) CWE-19 vulnerability in mercurial. A fix is available for mercurial — see the affected versions and patch details below.

Mercurial arbitrary code execution vulnerability

Also known asGHSA-9vjf-jjcq-3gh7PYSEC-2016-29
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
4.33%4.79%5.24%5.69%5.2%4.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mercurial

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImercurialall versions3.7.3pip install --upgrade 'mercurial==3.7.3'

Affected Products

7 products · 11 configurations
OS
debian linuxdebian
2 versions
7.08.0
OS
fedorafedoraproject
2 versions
2223
Application
mercurialmercurial
≤ 3.7.2
range
OS
leapopensuse
1 version
42.1
OS
opensuseopensuse
1 version
13.2
Application
linux enterprise debuginfosuse
1 version
11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mercurial, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mercurial to 3.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3630 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.
O3 Security · Impact-Aware SCA

Is CVE-2016-3630 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-3630: mercurial RCE — Fixed in 3.7.3