NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-3069 — mercurial

HIGH

CVE-2016-3069 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in mercurial. A fix is available for mercurial — see the affected versions and patch details below.

Mercurial vulnerable to arbitrary code execution via a crafted name when converting a Git repository

Also known asGHSA-8fm8-7365-5rh2PYSEC-2016-27
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
2.19%3.33%4.46%5.59%2.8%5.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mercurial

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted name when converting a Git repository.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImercurialall versions3.7.3pip install --upgrade 'mercurial==3.7.3'

Affected Products

14 products · 18 configurations
OS
debian linuxdebian
2 versions
7.08.0
OS
fedorafedoraproject
2 versions
2223
Application
mercurialmercurial
≤ 3.7.2
range
OS
leapopensuse
1 version
42.1
OS
opensuseopensuse
1 version
13.2
OS
enterprise linux desktopredhat
1 version
7.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mercurial, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mercurial to 3.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-3069 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 7mercurial-0:2.6.2-6.el7_2RHSA-2016:0706

Frequently Asked Questions

Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted name when converting a Git repository.
O3 Security · Impact-Aware SCA

Is CVE-2016-3069 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-3069: mercurial RCE — Fixed in 3.7.3