NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2017-1000018 — phpmyadmin

HIGH

CVE-2017-1000018 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin DoS Vulnerability

Also known asGHSA-47qr-f86f-3wm4
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.79%1.30%1.81%2.33%1.3%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

phpMyAdmin 4.0, 4.4., and 4.6 are vulnerable to a DOS attack in the replication status by using a specially crafted table name

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.6&&< 4.6.64.6.6composer require phpmyadmin/phpmyadmin:^4.6.6
🐘Packagistphpmyadmin/phpmyadmin≥ 4.4&&< 4.4.15.104.4.15.10composer require phpmyadmin/phpmyadmin:^4.4.15.10
🐘Packagistphpmyadmin/phpmyadmin≥ 4.0&&< 4.0.10.194.0.10.19composer require phpmyadmin/phpmyadmin:^4.0.10.19

Affected Products

1 product · 3 configurations
Application
phpmyadminphpmyadmin
≥ 4.6.0 && < 4.6.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.6.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000018 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

phpMyAdmin 4.0, 4.4., and 4.6 are vulnerable to a DOS attack in the replication status by using a specially crafted table name
O3 Security · Impact-Aware SCA

Is CVE-2017-1000018 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-1000018: phpmyadmin DoS — Fixed in 4.6.6