NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2017-1000017 — phpmyadmin

HIGH

CVE-2017-1000017 is a high-severity (CVSS 8.8) Server-Side Request Forgery (SSRF) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin SSRF in replication

Also known asGHSA-99xj-xqc9-98hr
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.42%0.90%1.37%1.85%0.9%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.6&&< 4.6.64.6.6composer require phpmyadmin/phpmyadmin:^4.6.6
🐘Packagistphpmyadmin/phpmyadmin≥ 4.4&&< 4.4.15.104.4.15.10composer require phpmyadmin/phpmyadmin:^4.4.15.10
🐘Packagistphpmyadmin/phpmyadmin≥ 4.0&&< 4.0.10.194.0.10.19composer require phpmyadmin/phpmyadmin:^4.0.10.19

Affected Products

1 product · 3 configurations
Application
phpmyadminphpmyadmin
≥ 4.6.0 && ≤ 4.6.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.6.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000017 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server
O3 Security · Impact-Aware SCA

Is CVE-2017-1000017 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-1000017: phpmyadmin — Fixed in 4.6.6