CVE-2017-1000015 — phpmyadmin
MEDIUMCVE-2017-1000015 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
phpMyAdmin CSS Injection Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
phpMyAdmin 4.0, 4.4, and 4.6 are vulnerable to a CSS injection attack through crafted cookie parameters
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.6.0&&< 4.6.6 | 4.6.6composer require phpmyadmin/phpmyadmin:^4.6.6 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.4.0&&< 4.4.15.10 | 4.4.15.10composer require phpmyadmin/phpmyadmin:^4.4.15.10 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.0.0&&< 4.0.10.19 | 4.0.10.19composer require phpmyadmin/phpmyadmin:^4.0.10.19 |
Affected Products
phpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 4.6.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000015 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-1000015 in your dependencies?
Find it across Packagist, including transitive dependencies.