NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2017-0931 — html-janitor

MEDIUM

CVE-2017-0931 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in html-janitor. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for html-janitor — see the affected versions and patch details below.

Cross-Site Scripting in html-janitor

Also known asGHSA-hfj4-96f7-6r5g
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.52%1.04%1.56%0.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

15other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
html-janitornpm
477Kdownloads / week

Description

Versions of html-janitor prior to 2.0.2 (all current versions) are vulnerable to cross-site scripting (XSS).

This is exploitable if user-controlled data is passed into the modules clean() function.

Recommendation

No fix is currently available for this vulnerability. It is recommended to use an alternative module for HTML sanitization.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmhtml-janitorall versions2.0.3npm install html-janitor@2.0.3

Affected Products

1 product · 1 configurations
Application
html-janitorhtml-janitor_project
1 version
2.0.2
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for html-janitor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update html-janitor to 2.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-0931 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Versions of `html-janitor` prior to 2.0.2 (all current versions) are vulnerable to cross-site scripting (XSS). This is exploitable if user-controlled data is passed into the modules `clean()` function. ## Recommendation No fix is currently available for this vulnerability. It is recommended to use an alternative module for HTML sanitization.
O3 Security · Impact-Aware SCA

Is CVE-2017-0931 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2017-0931: html-janitor XSS — Fixed in 2.0.3