CVE-2017-0256 — Microsoft.AspNetCore.Mvc
MEDIUMCVE-2017-0256 is a medium-severity (CVSS 5.3) Improper Input Validation vulnerability in Microsoft.AspNetCore.Mvc. A fix is available for Microsoft.AspNetCore.Mvc — see the affected versions and patch details below.
Moderate severity vulnerability that affects Microsoft.AspNetCore.Mvc
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Microsoft.AspNetCore.Mvc.NETMicrosoft.AspNetCore.Mvc.NETMicrosoft.AspNetCore.Mvc.Core.NETMicrosoft.AspNetCore.Mvc.Core.NETSystem.Net.Http.NETSystem.Net.Http.NETSystem.Text.Encodings.Web.NETSystem.Text.Encodings.Web+30 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
A spoofing vulnerability exists when the ASP.NET Core fails to properly sanitize web requests.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Microsoft.AspNetCore.Mvc | ≥ 1.0.0&&< 1.0.4 | 1.0.4dotnet add package Microsoft.AspNetCore.Mvc --version 1.0.4 |
| .NETNuGet | Microsoft.AspNetCore.Mvc | ≥ 1.1.0&&< 1.1.3 | 1.1.3dotnet add package Microsoft.AspNetCore.Mvc --version 1.1.3 |
| .NETNuGet | Microsoft.AspNetCore.Mvc.Core | ≥ 1.0.0&&< 1.0.4 | 1.0.4dotnet add package Microsoft.AspNetCore.Mvc.Core --version 1.0.4 |
| .NETNuGet | Microsoft.AspNetCore.Mvc.Core | ≥ 1.1.0&&< 1.1.3 | 1.1.3dotnet add package Microsoft.AspNetCore.Mvc.Core --version 1.1.3 |
| .NETNuGet | System.Net.Http | ≥ 4.1.1&&< 4.1.2 | 4.1.2dotnet add package System.Net.Http --version 4.1.2 |
| .NETNuGet | System.Net.Http | ≥ 4.3.1&&< 4.3.2 | 4.3.2dotnet add package System.Net.Http --version 4.3.2 |
Affected Products
asp.net model view controllermicrosoftmicrosoft.aspnetcore.mvc.abstractionsmicrosoftmicrosoft.aspnetcore.mvc.apiexplorermicrosoftmicrosoft.aspnetcore.mvc.corsmicrosoftmicrosoft.aspnetcore.mvc.dataannotationsmicrosoftmicrosoft.aspnetcore.mvc.formatters.jsonmicrosoftDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.Mvc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Microsoft.AspNetCore.Mvc to 1.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-0256 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-0256 in your dependencies?
Find it across NuGet, including transitive dependencies.