NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET NuGet
Not in CISA KEV

CVE-2017-0248 — Microsoft.AspNetCore.Mvc

CVE-2017-0248 is a CWE-295 vulnerability in Microsoft.AspNetCore.Mvc. A fix is available for Microsoft.AspNetCore.Mvc — see the affected versions and patch details below.

Moderate severity vulnerability that affects Microsoft.AspNetCore.Mvc and Microsoft.AspNetCore.Mvc.Core

Published
Updated
Affected
38 pkgs
Patched
38 / 38
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.00%2.28%4.56%6.84%1.1%5.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

38 pkgs affected
.NETMicrosoft.AspNetCore.Mvc.NETMicrosoft.AspNetCore.Mvc.NETMicrosoft.AspNetCore.Mvc.Core.NETMicrosoft.AspNetCore.Mvc.Core.NETSystem.Net.Http.NETSystem.Net.Http.NETSystem.Text.Encodings.Web.NETSystem.Text.Encodings.Web+30 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Microsoft .NET Framework 2.0, 3.5, 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2 and 4.7 allow an attacker to bypass Enhanced Security Usage taggings when they present a certificate that is invalid for a specific use, aka ".NET Security Feature Bypass Vulnerability."

Affected Packages

38 total 38 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMicrosoft.AspNetCore.Mvc≥ 1.0.0&&< 1.0.41.0.4dotnet add package Microsoft.AspNetCore.Mvc --version 1.0.4
.NETNuGetMicrosoft.AspNetCore.Mvc≥ 1.1.0&&< 1.1.31.1.3dotnet add package Microsoft.AspNetCore.Mvc --version 1.1.3
.NETNuGetMicrosoft.AspNetCore.Mvc.Core≥ 1.0.0&&< 1.0.41.0.4dotnet add package Microsoft.AspNetCore.Mvc.Core --version 1.0.4
.NETNuGetMicrosoft.AspNetCore.Mvc.Core≥ 1.1.0&&< 1.1.31.1.3dotnet add package Microsoft.AspNetCore.Mvc.Core --version 1.1.3
.NETNuGetSystem.Net.Http≥ 4.1.1&&< 4.1.24.1.2dotnet add package System.Net.Http --version 4.1.2
.NETNuGetSystem.Net.Http≥ 4.3.1&&< 4.3.24.3.2dotnet add package System.Net.Http --version 4.3.2

Affected Products

1 product · 8 configurations
Application
.net frameworkmicrosoft
8 versions
2.03.53.5.14.5.24.64.6.14.6.24.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.Mvc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Microsoft.AspNetCore.Mvc to 1.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-0248 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Microsoft .NET Framework 2.0, 3.5, 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2 and 4.7 allow an attacker to bypass Enhanced Security Usage taggings when they present a certificate that is invalid for a specific use, aka ".NET Security Feature Bypass Vulnerability."
O3 Security · Impact-Aware SCA

Is CVE-2017-0248 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2017-0248: Microsoft.AspNetCore.Mvc — Fixed in 1.0.4