CVE-2017-0247 — Microsoft.AspNetCore.Mvc
HIGHCVE-2017-0247 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in Microsoft.AspNetCore.Mvc. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for Microsoft.AspNetCore.Mvc — see the affected versions and patch details below.
ASP.NET Core fails to properly validate web requests
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Microsoft.AspNetCore.Mvc.NETMicrosoft.AspNetCore.Mvc.NETMicrosoft.AspNetCore.Mvc.Core.NETMicrosoft.AspNetCore.Mvc.Core.NETSystem.Net.Http.NETSystem.Net.Http.NETSystem.Text.Encodings.Web.NETSystem.Text.Encodings.Web+30 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
A denial of service vulnerability exists when the ASP.NET Core fails to properly validate web requests. NOTE: Microsoft has not commented on third-party claims that the issue is that the TextEncoder.EncodeCore function in the System.Text.Encodings.Web package in ASP.NET Core Mvc before 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to cause a denial of service by leveraging failure to properly calculate the length of 4-byte characters in the Unicode Non-Character range.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Microsoft.AspNetCore.Mvc | ≥ 1.0.0&&< 1.0.4 | 1.0.4dotnet add package Microsoft.AspNetCore.Mvc --version 1.0.4 |
| .NETNuGet | Microsoft.AspNetCore.Mvc | ≥ 1.1.0&&< 1.1.3 | 1.1.3dotnet add package Microsoft.AspNetCore.Mvc --version 1.1.3 |
| .NETNuGet | Microsoft.AspNetCore.Mvc.Core | ≥ 1.0.0&&< 1.0.4 | 1.0.4dotnet add package Microsoft.AspNetCore.Mvc.Core --version 1.0.4 |
| .NETNuGet | Microsoft.AspNetCore.Mvc.Core | ≥ 1.1.0&&< 1.1.3 | 1.1.3dotnet add package Microsoft.AspNetCore.Mvc.Core --version 1.1.3 |
| .NETNuGet | System.Net.Http | ≥ 4.1.1&&< 4.1.2 | 4.1.2dotnet add package System.Net.Http --version 4.1.2 |
| .NETNuGet | System.Net.Http | ≥ 4.3.1&&< 4.3.2 | 4.3.2dotnet add package System.Net.Http --version 4.3.2 |
Affected Products
asp.net model view controllermicrosoftmicrosoft.aspnetcore.mvc.abstractionsmicrosoftmicrosoft.aspnetcore.mvc.apiexplorermicrosoftmicrosoft.aspnetcore.mvc.corsmicrosoftmicrosoft.aspnetcore.mvc.dataannotationsmicrosoftmicrosoft.aspnetcore.mvc.formatters.jsonmicrosoftResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.Mvc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Microsoft.AspNetCore.Mvc to 1.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-0247 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2017-0247 in your dependencies?
Find it across NuGet, including transitive dependencies.