NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2016-5701 — phpmyadmin

MEDIUMFix: phpmyadmin/phpmyadmin@1dca386

CVE-2016-5701 is a medium-severity (CVSS 6.1) CWE-74 vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

phpMyAdmin vulnerable to Cross-site Scripting

Also known asGHSA-rh74-5835-jpxp
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.68%1.37%2.05%0.5%1.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

setup/frames/index.inc.php in phpMyAdmin 4.0.10.x before 4.0.10.16, 4.4.15.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to conduct BBCode injection attacks against HTTP sessions via a crafted URI.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.0.10.0&&< 4.0.10.164.0.10.16composer require phpmyadmin/phpmyadmin:^4.0.10.16
🐘Packagistphpmyadmin/phpmyadmin≥ 4.4.15.0&&< 4.4.15.74.4.15.7composer require phpmyadmin/phpmyadmin:^4.4.15.7
🐘Packagistphpmyadmin/phpmyadmin≥ 4.6.0&&< 4.6.34.6.3composer require phpmyadmin/phpmyadmin:^4.6.3

Affected Products

3 products · 62 configurations
OS
leapopensuse
1 version
42.1
OS
opensuseopensuse
2 versions
13.113.2
Application
phpmyadminphpmyadmin
56 versions
4.0.04.0.14.0.24.0.34.0.44.0.4.14.0.4.24.0.54.0.64.0.74.0.84.0.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.0.10.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-5701 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

setup/frames/index.inc.php in phpMyAdmin 4.0.10.x before 4.0.10.16, 4.4.15.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to conduct BBCode injection attacks against HTTP sessions via a crafted URI.
O3 Security · Impact-Aware SCA

Is CVE-2016-5701 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2016-5701: phpmyadmin RCE — Fixed in 4.0.10.16