CVE-2016-4911 is a medium-severity (CVSS 4.3) CWE-284 vulnerability in keystone. A fix is available for keystone — see the affected versions and patch details below.
OpenStack Identity Keystone Improper Access Control
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
keystoneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The Fernet Token Provider in OpenStack Identity (Keystone) 9.0.x before 9.0.1 (mitaka) allows remote authenticated users to prevent revocation of a chain of tokens and bypass intended access restrictions by rescoping a token.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | keystone | ≥ 9.0.0&&< 9.0.1 | 9.0.1pip install --upgrade 'keystone==9.0.1' |
Affected Products
openstack identitykeystoneDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update keystone to 9.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4911 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2016-4911 in your dependencies?
Find it across PyPI, including transitive dependencies.