NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2016-4808 — web2py

HIGH

CVE-2016-4808 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in web2py. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for web2py — see the affected versions and patch details below.

Web2py Cross-Site Request Forgery vulnerability

Also known asGHSA-gp69-xcm6-ffqjPYSEC-2026-1061
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.75%1.50%2.26%0.2%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍web2py

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Web2py versions 2.14.5 and below was affected by CSRF (Cross Site Request Forgery) vulnerability, which allows an attacker to trick a logged in user to perform some unwanted actions i.e An attacker can trick an victim to disable the installed application just by sending a URL to victim.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIweb2pyall versions2.14.6pip install --upgrade 'web2py==2.14.6'

Affected Products

1 product · 1 configurations
Application
web2pyweb2py
≤ 2.14.5
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-39821webappspython✓ Verified

Web2py 2.14.5 - Multiple Vulnerabilities

by Narendra Bhati · May 16, 2016

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for web2py, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update web2py to 2.14.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4808 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Web2py versions 2.14.5 and below was affected by CSRF (Cross Site Request Forgery) vulnerability, which allows an attacker to trick a logged in user to perform some unwanted actions i.e An attacker can trick an victim to disable the installed application just by sending a URL to victim.
O3 Security · Impact-Aware SCA

Is CVE-2016-4808 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-4808: web2py CSRF — Fixed in 2.14.6