NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2016-10321 — web2py

CRITICALFix: web2py/web2py@944d8bd

CVE-2016-10321 is a critical-severity (CVSS 9.8) CWE-254 vulnerability in web2py. A fix is available for web2py — see the affected versions and patch details below.

web2py is vulnerable to password brute-force attack

Also known asGHSA-gv85-wgxc-vc56PYSEC-2026-569
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%1.08%2.17%3.25%0.5%2.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍web2py

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIweb2pyall versions2.14.6pip install --upgrade 'web2py==2.14.6'

Affected Products

1 product · 1 configurations
Application
web2pyweb2py
≤ 2.14.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for web2py, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update web2py to 2.14.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-10321 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.
O3 Security · Impact-Aware SCA

Is CVE-2016-10321 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-10321: web2py — Fixed in 2.14.6