NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2016-4428 — horizon

MEDIUMFix: openstack/horizon@62b4e6f

CVE-2016-4428 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in horizon. A fix is available for horizon — see the affected versions and patch details below.

OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability

Also known asGHSA-grm6-x6mr-q3cvPYSEC-2026-643
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.05%0.90%1.74%2.58%0.6%2.1%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍horizon🐍horizon

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIhorizonall versions8.0.2pip install --upgrade 'horizon==8.0.2'
🐍PyPIhorizon≥ 9.0.0&&< 9.1.09.1.0pip install --upgrade 'horizon==9.1.0'

Affected Products

3 products · 9 configurations
OS
debian linuxdebian
2 versions
8.09.0
Application
horizonopenstack
≥ 8.0.0 && ≤ 8.0.1
2 versions
9.0.09.0.1
Application
openstackredhat
4 versions
5.06.07.08

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for horizon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update horizon to 8.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4428 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6python-django-horizon-0:2014.1.5-4.el6ostRHSA-2016:1268
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7python-django-horizon-0:2014.1.5-4.el7ostRHSA-2016:1269
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7python-django-horizon-0:2014.2.3-9.el7ostRHSA-2016:1271
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7python-django-horizon-0:2015.1.4-1.el7ostRHSA-2016:1272
Red Hat OpenStack Platform 8.0 (Liberty)python-django-horizon-1:8.0.1-4.el7ostRHSA-2016:1270
UbuntuMEDIUM

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.
O3 Security · Impact-Aware SCA

Is CVE-2016-4428 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-4428: horizon XSS — Fixed in 8.0.2