CVE-2016-2559 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
phpMyAdmin Cross-site scripting (XSS) vulnerability in SQL parser
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the format function in libraries/sql-parser/src/Utils/Error.php in the SQL parser in phpMyAdmin 4.5.x before 4.5.5.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted query.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.5&&< 4.5.5.1 | 4.5.5.1composer require phpmyadmin/phpmyadmin:^4.5.5.1 |
Affected Products
phpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 4.5.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2559 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2016-2559 in your dependencies?
Find it across Packagist, including transitive dependencies.