NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2016-2140 — nova

MEDIUMFix: openstack/nova@0b19418

CVE-2016-2140 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in nova. A fix is available for nova — see the affected versions and patch details below.

OpenStack Nova host data access through resize/migration

Also known asGHSA-49jv-37hm-6gfpPYSEC-2026-864
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.88%1.76%2.64%0.6%2.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍nova

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The libvirt driver in OpenStack Compute (Nova) before 2015.1.4 (kilo) and 12.0.x before 12.0.3 (liberty), when using raw storage and use_cow_images is set to false, allows remote authenticated users to read arbitrary files via a crafted qcow2 header in an ephemeral or root disk.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInova≥ 12.0.0&&< 12.0.312.0.3pip install --upgrade 'nova==12.0.3'

Affected Products

1 product · 2 configurations
Application
novaopenstack
≥ 2015.1.0 && < 2015.1.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nova to 12.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-2140 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6openstack-nova-0:2014.1.5-29.el6ostRHSA-2016:0366
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7openstack-nova-0:2014.1.5-29.el7ostRHSA-2016:0365
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7openstack-nova-0:2014.2.3-54.2.el7ostRHSA-2016:0364
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7openstack-nova-0:2015.1.2-18.2.el7ostRHSA-2016:0363
UbuntuMEDIUM

Frequently Asked Questions

The libvirt driver in OpenStack Compute (Nova) before 2015.1.4 (kilo) and 12.0.x before 12.0.3 (liberty), when using raw storage and use_cow_images is set to false, allows remote authenticated users to read arbitrary files via a crafted qcow2 header in an ephemeral or root disk.
O3 Security · Impact-Aware SCA

Is CVE-2016-2140 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-2140: nova — Fixed in 12.0.3